Ld: library not found for -ldart-gui-osg

I am trying to install dartpy on my Mac OS X Catalina using the instructions given here but I get the error “ld: library not found for -ldart-gui-osg” when building the dartpy target. OSG was installed using this brew tap.

Any ideas as to why this is happening?